This project has moved and is read-only. For the latest updates, please go here.

What are the requirements?

Jun 10, 2013 at 6:04 PM
What are the requirements for the following.
  1. Server (i.e. Windows Server 2008/2012)
  2. Framework Version (i.e. .Net 4.0/4.5)
Others?
Jun 10, 2013 at 6:48 PM
v1 - (Microsoft.Owin.Host.SystemWeb)
.NET 4.0 (Win2k3).

v2 - (+ Self-host, Security, etc.)
.NET 4.0 (Win2k3), except the new Security packages are 4.5 (Win2008) only.

There is some debate about v2 dropping 4.0 and moving to 4.5 only (Win2008). Speak up now if you need 4.0 support.
Jun 10, 2013 at 10:06 PM
Yes, I think 4.0 support is still important for a while, and does that also include SignalR with Websocket support?

BTW, I'm TOTALLY impressed with Windows 2003 Server support!

We still have customers that we can't force off of Win2K3.

Thanks for the quick response.
Jun 10, 2013 at 11:35 PM
Katana supports anything .NET 4.0 supports, so we get Win2k3 for free. I won't claim we've tried it though. Let us know if it explodes?

WebSockets is 4.5 & Win8 only. Not our choice...

SignalR has already moved to 4.5 only for v2.
Jun 10, 2013 at 11:52 PM
Thanks!
Jun 14, 2013 at 3:48 PM
Which packages would you be using on 4.0? Web-host (SystemWeb), self-host (HttpListener), OwinHoste.exe?
Dec 9, 2013 at 3:56 PM
OWin.Security. would be very good if we would have that in 4.0
Dec 9, 2013 at 6:20 PM
Ms.Owin.Security is based on ClaimsPrincipal which is a new type in .NET 4.5.
Dec 10, 2013 at 7:51 AM
OK, I will try to compile it myself using ThinkTecture.IdentityModel (contains also a ClaimsPrincipal etc.). So I can still use the OWIN.Sec classes/Interfaces and migrate to 4.5 later on.

Thanks!