This project has moved. For the latest updates, please go here.

Katana/Microsoft.Owin.Security 2.0.0 - .NET4 supported?

Sep 16, 2013 at 11:58 AM
Hello!

I have a SignalR application that has to run self-hosted in .NET 4. I tried the new SignalR, but had troubles updating it.

SignalR 2.0.0-rc1 references Microsoft.Owin.Security 2.0.0-rc1. The security module claims that it needs .NET 4.5 when installing it with nuget (1.7.0). As far as I could figure out, Microsoft.Owin.Security is part of the Katana project, hence I ask in this form. Will Katana 2.0.0 still support .NET 4? Or will it require .NET 4.5 or 4.5.1?

Markus
Coordinator
Sep 16, 2013 at 2:44 PM
SignalR 2.0 only supports .NET 4.5. Katana's Security and Cors modules also require .NET 4.5. Most of the other katana modules support .NET 4.0.