This project has moved and is read-only. For the latest updates, please go here.

UseMicrosoftAccountAuthentication

Dec 12, 2013 at 4:06 AM
This doesn't seem to be working in the Katana.Sandbox.WebServer project or in my own project.

The 'Microsoft' button renders correctly along with buttons for the other providers, and as expected clicking it triggers a redirect to https://login.live.com.

What is not expected is the error message from live.com.

The HTML contains this generic message:
Microsoft account
We're unable to complete your request
Microsoft account is experiencing technical problems. Please try again later.

The real error appears in the URL, however:
https://login.live.com/err.srf?lc=1033#error=invalid_request&error_description=The%20provided%20value%20for%20the%20input%20parameter%20'redirect_uri'%20is%20not%20valid.%20The%20expected%20value%20is%20'https://login.live.com/oauth20_desktop.srf'%20or%20a%20URL%20which%20matches%20the%20redirect%20URI%20registered%20for%20this%20client%20application.&state=ux4WjWgfdOOiOAt8q4zbEPFrpZ3ENd5klGkhGpxW78bwmVlKqgbhhqfpGvZ8Gme0puWr_1rNrHiUS1ZHX2qB7UWMF0p9xkowsuoLAFRs8DGKFyCdclTHd8OJAm6dQqnK5145J25-vzq3264gYL7EfXdp3KiEw-H9gDrKLOzbH-c3uHNZYXExuQnGfORd7CNsBrDoz-FJOAtPogtbyuL8bcOhimb0Nmet-C2BspVQQeMVb4Kts6IVl-89jutbNr65nfpCdZYxczOC40fWcTzP7Q


So it's something to do with the redirect_uri, but I'm not familiar enough with Owin, Katana, or LiveConnect to know where the disconnect is.
Dec 12, 2013 at 5:18 PM
Dec 13, 2013 at 3:12 AM
It works!

Finally after so much digging around here and there and after deciding to read the instructions carefully.

I thought I had everything setup right locally ...I had mapped localhost to my domain in my hosts file and as far as I could tell my domain was being browsed as I tested. What I did not do was configure IIS Express to have the site bound to the domain and port 80.

This was the link that ended up helping.
http://www.asp.net/web-api/overview/security/external-authentication-services#MICROSOFT
(scroll down to where it says "Configuring IIS Express to use a Fully Qualified Domain Name")



Thanks Tratcher!
Sep 18, 2014 at 9:21 PM
Tratcher,

We've gotten everything (oAuth) working in dev and are configuring our staging server prior to rolling site out. I'd really like to test the production settings, modifying local HOSTS to use the staging server as the production www.whateverdomainis.com Is that possible? I am getting the same error as above and also w/ Facebook, twitter, which I'm assuming probably are similar errors.

Thanks!

jbpeek
Sep 18, 2014 at 9:45 PM
Yes, modifying the host file should work. Note the changes may not be picked up immediately.
Sep 19, 2014 at 3:11 PM
The issue ended up being my test app had the deprecated Don't authenticate redirect URL' found my redirect was off for msft

Sent from my Windows Phone