This project has moved and is read-only. For the latest updates, please go here.

KatanaEngine fails when using F#-startup

May 23, 2013 at 12:41 PM
Edited May 23, 2013 at 12:43 PM

works perfectly on a C#-class:
    public class MyClass
        public void Configuration(IAppBuilder app)
but fails if I try to use it with F#-class:
type MyClass() =
    member x.Configuration(app:Owin.IAppBuilder) = 
It fails in KatanaEngine.cs method ResolveApp(StartContext context) in line:
throw new EntryPointNotFoundException(Resources.Exception_MissingApplicationEntryPoint);

(Other than that, F#-hosting is working fine, so workaround is to make dummy-C#-project with only this one class...)
May 24, 2013 at 8:30 PM
I tried this on the latest bits and it worked.

The only thing I had to change in my app was to make sure the return type was void:
type MyClass() =
member x.Configuration(app:Owin.IAppBuilder) =
    let y = app.ToString()
And if it doesn't work for you, at least the error messages should be more helpful now.
May 28, 2013 at 10:53 PM