This project has moved and is read-only. For the latest updates, please go here.

Web Api Self Host with SSL

Nov 20, 2013 at 3:55 PM
Any chance someone has any idea how to setup host with SSL with Web Api 2?

Can't find ClientCredentialType ...
Nov 20, 2013 at 7:48 PM
Ok I found this link https://pfelix.wordpress.com/2012/02/26/enabling-https-with-self-hosted-asp-net-web-api/

But still nothing works.

I just need the Owin Selft Host with support for https.
Nov 20, 2013 at 8:28 PM
Nov 20, 2013 at 9:50 PM
Not quite.
I have a certificate setup on port 9443, with my App GUID.
But as soon as I change my startup host adress to Https, nothing works.
I have to way of knowing why my request doesn't get to the controller.
Nov 20, 2013 at 10:26 PM
What errors does it give you?
Nov 21, 2013 at 2:20 PM
I have no error messages, The request never hits the controller.
The response code I get is 502.
Nov 21, 2013 at 5:30 PM
Come to https://jabbr.net/#/rooms/owin and we can talk about this more.
Nov 21, 2013 at 9:38 PM
Latest update on the subject.

I get a 503 Service unavailable response now.

Seems like the HttpListener is not "listening"
Nov 22, 2013 at 2:53 PM
I was able to validate my certificate setup on my port (9443) with a separate project hosting a simple httplistener.
The requests are coming through.
Nov 22, 2013 at 7:19 PM
Finally got it to work!!
My error was with the url for the Startup.
I was using "https://localhost:9443/" Instead, I need to use this: "https://+:9443/" Hope it helps someone.
Oct 6, 2014 at 2:11 PM
Dude, you saved my afternoon! i also had this problem where it would not listen on any external hostname or even on the same machine with the external ip. setting the host as http://+:port solved everything.

it seems obvious now but i think alot of people get stuck in this situation, there are a fair few threads on SO about similar issues. Maybe this can be highlighted in the comments of documentation? :)